<!DOCTYPE html>
<html lang="en-GB" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width,initial-scale=1">
<title>Gardens of Jannah: Actions of the Messenger ﷺ were Continuous (Deemah ديمة) | Khilafah.com</title>
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.khilafah.com/xmlrpc.php">
<!--[if lt IE 9]>
		<script src="http://www.khilafah.com/wp-content/themes/zuki/js/html5.js"></script>
	<![endif]-->

<link rel="canonical" href="http://www.khilafah.com/gardens-of-jannah-actions-of-the-messenger-ﷺ-were-continuous-deemah-ديمة/" />

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//k4z6w9b5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="Khilafah.com &raquo; Feed" href="http://www.khilafah.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Khilafah.com &raquo; Comments Feed" href="http://www.khilafah.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Khilafah.com &raquo; Gardens of Jannah: Actions of the Messenger ﷺ were Continuous (Deemah ديمة) Comments Feed" href="http://www.khilafah.com/gardens-of-jannah-actions-of-the-messenger-%ef%b7%ba-were-continuous-deemah-%d8%af%d9%8a%d9%85%d8%a9/feed/" />

<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script' />
<script data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/www.khilafah.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"http:\/\/www.khilafah.com\/wp-admin\/admin-ajax.php"},"url_components":{"year":"2020","monthnum":"12","day":"29","hour":"17","minute":"41","second":"57","post_id":"47763","postname":"gardens-of-jannah-actions-of-the-messenger-%ef%b7%ba-were-continuous-deemah-%d8%af%d9%8a%d9%85%d8%a9","category":"concepts"}};
  //]]>
</script>
<script data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='dfeac585de5f8d95d406ad242873dbec' async>
</script>

<meta name='shareaholic:site_name' content='Khilafah.com' />
<meta name='shareaholic:language' content='en-GB' />
<meta name='shareaholic:url' content='http://www.khilafah.com/gardens-of-jannah-actions-of-the-messenger-%ef%b7%ba-were-continuous-deemah-%d8%af%d9%8a%d9%85%d8%a9/' />
<meta name='shareaholic:keywords' content='concepts, featured, islamic culture, post' />
<meta name='shareaholic:article_published_time' content='2020-12-29T17:41:57+00:00' />
<meta name='shareaholic:article_modified_time' content='2020-12-29T17:41:57+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Editorial' />
<meta name='shareaholic:site_id' content='dfeac585de5f8d95d406ad242873dbec' />
<meta name='shareaholic:wp_version' content='8.12.6' />
<meta name='shareaholic:image' content='http://www.khilafah.com/wp-content/uploads/2016/01/medina-mosque-300x225.jpg' />


<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.6.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-23343321-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-23343321-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.khilafah.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='http://www.khilafah.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='zuki-flex-slider-style-css' href='http://www.khilafah.com/wp-content/themes/zuki/js/flex-slider/flexslider.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='zuki-fonts-css' href='//fonts.googleapis.com/css?family=Libre+Baskerville%3A400%2C700%2C400italic%7CKarla%3A400%2C400italic%2C700%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css' href='http://www.khilafah.com/wp-content/themes/zuki/genericons/genericons.css?ver=3.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='zuki-style-css' href='http://www.khilafah.com/wp-content/themes/zuki/style.css?ver=20140630' type='text/css' media='all' />
<link rel='stylesheet' id='msl-main-css' href='http://www.khilafah.com/wp-content/plugins/master-slider/public/assets/css/masterslider.main.css?ver=3.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css' href='http://www.khilafah.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=13.1' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"http:\/\/www.khilafah.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.khilafah.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.6.0'></script>
<script type='text/javascript' src='http://www.khilafah.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.khilafah.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.khilafah.com/wp-content/themes/zuki/js/jquery.fitvids.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.khilafah.com/wp-content/themes/zuki/js/flex-slider/jquery.flexslider-min.js?ver=5.1.1'></script>
<script type='text/javascript' src='http://www.khilafah.com/wp-content/themes/zuki/js/functions.js?ver=20140426'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"http:\/\/www.khilafah.com\/wp-admin\/admin-ajax.php","security":"7621a2e226","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/www.khilafah.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"http:\/\/www.khilafah.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"13.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.khilafah.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=13.1'></script>
<link rel='https://api.w.org/' href='http://www.khilafah.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.khilafah.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.khilafah.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Sri Lankan Government’s Exploitation of the Covid-19 Pandemic in Cremating Muslims!' href='http://www.khilafah.com/sri-lankan-governments-exploitation-of-the-covid-19-pandemic-in-cremating-muslims/' />
<meta name="generator" content="WordPress 5.1.1" />
<link rel='shortlink' href='http://www.khilafah.com/?p=47763' />
<link rel="alternate" type="application/json+oembed" href="http://www.khilafah.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.khilafah.com%2Fgardens-of-jannah-actions-of-the-messenger-%25ef%25b7%25ba-were-continuous-deemah-%25d8%25af%25d9%258a%25d9%2585%25d8%25a9%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.khilafah.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.khilafah.com%2Fgardens-of-jannah-actions-of-the-messenger-%25ef%25b7%25ba-were-continuous-deemah-%25d8%25af%25d9%258a%25d9%2585%25d8%25a9%2F&#038;format=xml" />
<style>.ms-parent-id-1 > .master-slider{ background:#000000; }</style>
<script>var ms_grabbing_curosr = 'http://www.khilafah.com/wp-content/plugins/master-slider/public/assets/css/common/grabbing.cur', ms_grab_curosr = 'http://www.khilafah.com/wp-content/plugins/master-slider/public/assets/css/common/grab.cur';</script>
<meta name="generator" content="MasterSlider 3.5.3 - Responsive Touch Image Slider | avt.li/msf" />
<style type="text/css">
		.widget-area p.summary a,
		.entry-content p a,
		blockquote cite a,
		.textwidget a,
		#comments .comment-text a,
		.authorbox p.author-description a {color: ;}
		.widget_zuki_recentposts_color .bg-wrap {background: ;}
		.archive-menu-content {background: ;}
	</style>
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<style type="text/css" id="zuki-header-css">
			#site-title h1,
		#site-title h2.site-description {
			display: none;
		}

		</style>


<meta property="og:locale" content="en_GB" />
<meta property="og:site_name" content="Khilafah.com" />
<meta property="og:title" content="Gardens of Jannah: Actions of the Messenger ﷺ were Continuous (Deemah ديمة)" />
<meta property="og:url" content="http://www.khilafah.com/gardens-of-jannah-actions-of-the-messenger-%ef%b7%ba-were-continuous-deemah-%d8%af%d9%8a%d9%85%d8%a9/" />
<meta property="og:type" content="article" />
<meta property="og:description" content="بسم الله الرحمن الرحيم
- Bukhari and Muslim reported from Alqama: قُلْتُ لِعَائِشَةَ رَضِيَ اللَّهُ عَنْهَا هَلْ كَانَ رَسُولُ اللَّهِ صَلَّى اللَّهُ عَلَيْهِ وَسَلَّمَ يَخْتَصُّ مِنْ الْأَيَّامِ شَيْئًا؟ قَالَتْ: لَا، كَانَ عَمَلُهُ دِيمَةً، وَأَيُّكُمْ يُطِيقُ مَا كَانَ رَسُولُ اللَّهِ صَلَّى الل" />
<meta property="og:image" content="http://www.khilafah.com/wp-content/uploads/2016/01/medina-mosque.jpg" />
<meta property="og:image:url" content="http://www.khilafah.com/wp-content/uploads/2016/01/medina-mosque.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="768" />
<meta property="article:published_time" content="2020-12-29T17:41:57+00:00" />
<meta property="article:modified_time" content="2020-12-29T17:41:57+00:00" />
<meta property="og:updated_time" content="2020-12-29T17:41:57+00:00" />
<meta property="article:section" content="Concepts" />
<meta property="article:section" content="Featured" />
<meta property="article:section" content="Islamic Culture" />

<meta itemprop="name" content="Gardens of Jannah: Actions of the Messenger ﷺ were Continuous (Deemah ديمة)" />
<meta itemprop="headline" content="Gardens of Jannah: Actions of the Messenger ﷺ were Continuous (Deemah ديمة)" />
<meta itemprop="description" content="بسم الله الرحمن الرحيم
- Bukhari and Muslim reported from Alqama: قُلْتُ لِعَائِشَةَ رَضِيَ اللَّهُ عَنْهَا هَلْ كَانَ رَسُولُ اللَّهِ صَلَّى اللَّهُ عَلَيْهِ وَسَلَّمَ يَخْتَصُّ مِنْ الْأَيَّامِ شَيْئًا؟ قَالَتْ: لَا، كَانَ عَمَلُهُ دِيمَةً، وَأَيُّكُمْ يُطِيقُ مَا كَانَ رَسُولُ اللَّهِ صَلَّى الل" />
<meta itemprop="image" content="http://www.khilafah.com/wp-content/uploads/2016/01/medina-mosque.jpg" />
<meta itemprop="datePublished" content="2020-12-29" />
<meta itemprop="dateModified" content="2020-12-29T17:41:57+00:00" />
<meta itemprop="author" content="Editorial" />





</head>
<body class="post-template-default single single-post postid-47763 single-format-standard _masterslider _ms_version_3.5.3">
<div id="container">
<header id="masthead" class="cf" role="banner">
<nav id="header-top-nav">
<ul id="menu-top" class="menu"><li id="menu-item-26041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26041"><a href="http://www.khilafah.com/what-is-the-khilafah-caliphate/">What is Khilafah?</a></li>
<li id="menu-item-26044" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26044"><a href="http://www.khilafah.com/faq/">FAQ</a></li>
<li id="menu-item-26065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26065"><a href="http://www.khilafah.com/khilafah-organisation-chart/">Org Chart</a></li>
<li id="menu-item-25170" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-25170"><a href="http://www.khilafah.com/tag/syria/">Syria</a></li>
<li id="menu-item-45913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45913"><a href="http://www.khilafah.com/category/uighurs/">Uighurs</a></li>
<li id="menu-item-23027" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-23027"><a href="http://www.khilafah.com/tag/ata-al-rashtah/">Ata Abu Al-Rashtah</a></li>
<li id="menu-item-25971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25971"><a href="http://www.khilafah.com/about-us/">About us</a></li>
<li id="menu-item-22966" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-22966"><a href="http://www.khilafah.com/tag/qa/">Q&#038;A</a></li>
<li id="menu-item-30076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30076"><a href="http://www.khilafah.com/contact-us-2/">Contact Us</a></li>
</ul> </nav>
<div id="site-title">
<div id="site-header">
<a href="http://www.khilafah.com/" rel="home"><img src="http://www.khilafah.com/wp-content/uploads/2015/07/cropped-KcomLogo20151.png" width="420" height="73" alt=""></a>
</div>
<h1><a href="http://www.khilafah.com/" title="Khilafah.com">Khilafah.com</a></h1>
<h2 class="site-description">Serving the Ummah since 1996</h2>
</div>
<a href="#menuopen" id="mobile-menu-toggle"><span>Menu</span></a>
<div id="mobile-menu-wrap" class="cf">
<div class="search-box">
<a href="#" id="search-toggle"><span>Search</span></a>
<form role="search" method="get" id="searchform" class="searchform" action="http://www.khilafah.com/" role="search">
<label for="s" class="screen-reader-text"><span>Search</span></label>
<input type="text" class="search-field" name="s" id="s" placeholder="Type to search&hellip;" />
<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
</form> </div>
<nav id="site-nav" class="cf">
<ul id="menu-magazin" class="nav-menu"><li id="menu-item-21161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21161"><a href="http://www.khilafah.com/category/the-khilafah/">Khilafah</a>
<ul class="sub-menu">
<li id="menu-item-21170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21170"><a href="http://www.khilafah.com/category/the-khilafah/structure/">Structure</a></li>
<li id="menu-item-21200" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21200"><a href="http://www.khilafah.com/category/anniversary/c77-anniversary/">Anniversary</a></li>
<li id="menu-item-21187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21187"><a href="http://www.khilafah.com/category/the-khilafah/issues/">Issues</a></li>
<li id="menu-item-21191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21191"><a href="http://www.khilafah.com/category/the-khilafah/khilafah/">Khilafah</a></li>
<li id="menu-item-21195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21195"><a href="http://www.khilafah.com/category/the-khilafah/judiciary/">Judiciary</a></li>
<li id="menu-item-21198" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21198"><a href="http://www.khilafah.com/category/the-khilafah/education/">Education</a></li>
<li id="menu-item-21201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21201"><a href="http://www.khilafah.com/category/the-khilafah/non-muslims/">Non-Muslims</a></li>
<li id="menu-item-21203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21203"><a href="http://www.khilafah.com/category/the-khilafah/foreign-policy/">Foreign Policy</a></li>
<li id="menu-item-21207" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21207"><a href="http://www.khilafah.com/category/the-khilafah/social-system/">Social System</a></li>
</ul>
</li>
<li id="menu-item-40626" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40626"><a href="http://www.khilafah.com/category/analysis/c52-middle-east/">Middle East</a></li>
<li id="menu-item-23241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23241"><a href="http://www.khilafah.com/category/multimedia/books/">Books</a></li>
<li id="menu-item-21205" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21205"><a href="http://www.khilafah.com/category/the-khilafah/economy/">Economy</a></li>
<li id="menu-item-21162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21162"><a href="http://www.khilafah.com/category/analysis/">Analysis</a>
<ul class="sub-menu">
<li id="menu-item-21174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21174"><a href="http://www.khilafah.com/category/analysis/americas/">America</a></li>
<li id="menu-item-21175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21175"><a href="http://www.khilafah.com/category/analysis/c50-africa/">Africa</a></li>
<li id="menu-item-21178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21178"><a href="http://www.khilafah.com/category/analysis/asia/">Asia</a></li>
<li id="menu-item-21391" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21391"><a href="http://www.khilafah.com/category/analysis/central-asia-analysis/">Central Asia</a></li>
<li id="menu-item-21176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21176"><a href="http://www.khilafah.com/category/analysis/c51-europe/">Europe</a></li>
<li id="menu-item-21393" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21393"><a href="http://www.khilafah.com/category/analysis/an-south-asia/">South Asia</a></li>
<li id="menu-item-21194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21194"><a href="http://www.khilafah.com/category/concepts/political-concepts/">Political Concepts</a></li>
</ul>
</li>
<li id="menu-item-21172" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-21172"><a href="http://www.khilafah.com/category/concepts/islamic-culture/">Culture</a>
<ul class="sub-menu">
<li id="menu-item-29384" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29384"><a href="http://www.khilafah.com/category/concepts/islamic-culture/">Islamic Culture</a></li>
<li id="menu-item-21190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21190"><a href="http://www.khilafah.com/category/concepts/general-concepts/">General Concepts</a></li>
<li id="menu-item-21196" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21196"><a href="http://www.khilafah.com/category/concepts/belief/">Belief</a></li>
</ul>
</li>
<li id="menu-item-21165" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21165"><a href="http://www.khilafah.com/category/ativism/">Activism</a>
<ul class="sub-menu">
<li id="menu-item-21179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21179"><a href="http://www.khilafah.com/category/ativism/c55-asia/">Asia</a></li>
<li id="menu-item-21180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21180"><a href="http://www.khilafah.com/category/ativism/c56-africa/">Africa</a></li>
<li id="menu-item-21184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21184"><a href="http://www.khilafah.com/category/ativism/c72-central-asia/">Central Asia</a></li>
<li id="menu-item-27675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27675"><a href="http://www.khilafah.com/category/ativism/act-europe/">Europe</a></li>
<li id="menu-item-21181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21181"><a href="http://www.khilafah.com/category/ativism/c57-middle-east/">Middle East</a></li>
<li id="menu-item-21392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21392"><a href="http://www.khilafah.com/category/ativism/act-south-asia/">South Asia</a></li>
<li id="menu-item-21182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21182"><a href="http://www.khilafah.com/category/ativism/west/">West</a></li>
</ul>
</li>
</ul> </nav>
<a href="#menuclose" id="mobile-menu-close"><span>Close Menu</span></a>
</div>
</header>
<div id="main-wrap">
<div id="primary" class="site-content cf" role="main">
<article id="post-47763" class="post-47763 post type-post status-publish format-standard has-post-thumbnail hentry category-concepts category-featured category-islamic-culture">
<header class="entry-header">
<div class="entry-cats">
<a href="http://www.khilafah.com/category/concepts/" rel="category tag">Concepts</a>, <a href="http://www.khilafah.com/category/featured/" rel="category tag">Featured</a>, <a href="http://www.khilafah.com/category/concepts/islamic-culture/" rel="category tag">Islamic Culture</a> </div>
<div class="entry-date">
Published on <a href="http://www.khilafah.com/gardens-of-jannah-actions-of-the-messenger-%ef%b7%ba-were-continuous-deemah-%d8%af%d9%8a%d9%85%d8%a9/">29th December 2020</a>
</div>
<div class="entry-comments">
<a href="http://www.khilafah.com/gardens-of-jannah-actions-of-the-messenger-%ef%b7%ba-were-continuous-deemah-%d8%af%d9%8a%d9%85%d8%a9/#respond"><span class="leave-reply">Leave a comment</span></a> </div>
<h1 class="entry-title">Gardens of Jannah: Actions of the Messenger ﷺ were Continuous (Deemah ديمة)</h1>
<div class="entry-author">
written by <a href="http://www.khilafah.com/author/akeditor/" title="All posts by Al-Waie Magazine">Al-Waie Magazine</a> </div>
</header>
<div class="entry-thumbnail">
<a href="http://www.khilafah.com/gardens-of-jannah-actions-of-the-messenger-%ef%b7%ba-were-continuous-deemah-%d8%af%d9%8a%d9%85%d8%a9/" title="Permalink to Gardens of Jannah: Actions of the Messenger ﷺ were Continuous (Deemah ديمة)"><img width="1024" height="768" src="http://www.khilafah.com/wp-content/uploads/2016/01/medina-mosque.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://www.khilafah.com/wp-content/uploads/2016/01/medina-mosque.jpg 1024w, http://www.khilafah.com/wp-content/uploads/2016/01/medina-mosque-300x225.jpg 300w, http://www.khilafah.com/wp-content/uploads/2016/01/medina-mosque-768x576.jpg 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></a>
</div>
<div class="entry-content">
<p style="text-align: center;"><strong>بسم الله الرحمن الرحيم</strong></p>
<p>&#8211; Bukhari and Muslim reported from Alqama: <strong>قُلْتُ لِعَائِشَةَ رَضِيَ اللَّهُ عَنْهَا هَلْ كَانَ رَسُولُ اللَّهِ صَلَّى اللَّهُ عَلَيْهِ وَسَلَّمَ يَخْتَصُّ مِنْ الْأَيَّامِ شَيْئًا؟ قَالَتْ: لَا، كَانَ عَمَلُهُ دِيمَةً، وَأَيُّكُمْ يُطِيقُ مَا كَانَ رَسُولُ اللَّهِ صَلَّى اللَّهُ عَلَيْهِ وَسَلَّمَ يُطِيقُ؟</strong> <strong>“I asked `Aisha (ra): &#8220;Did the Messenger of Allah </strong><strong>ﷺ</strong><strong> use to choose some special days?&#8221; She replied, &#8220;No, but his deed was regular (constant) (in his service of worshipping). Who amongst you can endure what Allah&#8217;s Messenger </strong><strong>ﷺ</strong><strong> used to endure?&#8221;”</strong></p>
<p><span id="more-47763"></span></p>
<p>&#8211; Bukhari and Muslim reported from Masruq: <strong>سَأَلْتُ عَائِشَةَ رَضِيَ اللَّهُ عَنْهَا: أَيُّ الْعَمَلِ كَانَ أَحَبَّ إِلَى النَّبِيِّ صَلَّى اللَّهُ عَلَيْهِ وَسَلَّمَ؟ قَالَتْ: الدَّائِمُ</strong> <strong>“I asked Aisha (ra), &#8220;What deed was the most beloved to the Prophet?&#8221; She said, &#8220;The regular constant one.&#8221;”</strong></p>
<p><strong>&#8211; </strong>Bukhari and Muslim reported: The Messenger of Allah ﷺ was asked about the act most pleasing to Allah.<strong> He </strong><strong>ﷺ</strong><strong> replied: </strong><strong>»</strong> <strong>أَدْوَمُهَا وَإِنْ قَلَّ</strong> <strong>«</strong> <strong>“That which is done continuously, even if it is small.”</strong></p>
<p>&#8211; Muslim narrated from Aisha (ra): <strong>كَانَ رَسُولُ اللَّهِ صَلَّى اللَّهُ عَلَيْهِ وَسَلَّمَ إِذَا عَمِلَ عَمَلًا أَثْبَتَهُ، وَكَانَ إِذَا نَامَ مِنْ اللَّيْلِ أَوْ مَرِضَ صَلَّى مِنْ النَّهَارِ ثِنْتَيْ عَشْرَةَ رَكْعَةً</strong> <strong>“When the Messenger of Allah </strong><strong>ﷺ</strong><strong> performed any deed, he continued to do it, and when he slept at night or fell sick he performed twelve rak&#8217;ahs prayer during the daytime.”</strong></p>
<p>An-Nawawi (rh) commented on the saying of Aisha (ra): “(<strong>كَانَ عَمَله دِيمَة</strong>) “<strong>His </strong><strong>ﷺ</strong><strong> deed was regular</strong>” i.e. he ﷺ continued to perform it and he did not break it”. Al-Hafidh (Ibn Hajar) (rah) says: “Linguists say that the word ‘الدِّيمَةُ’ (Deemah) refers to continuous rain, on every day and then it refers to all that is continuous”.</p>
<p>There are Ahadeeth of the Messenger ﷺ that show that he ﷺ persevered, persisted and continuously undertook actions that bring closeness to Allah. Some of them are:</p>
<p>Tirmidhi reported from Aisha (ra) that the Messenger of Allah ﷺ said: <strong>«</strong><strong>مَنْ ثَابَرَ عَلَى ثِنْتَيْ عَشْرَةَ رَكْعَةً مِنْ السُّنَّةِ بَنَى اللَّهُ لَهُ بَيْتًا فِي الْجَنَّةِ</strong><strong>»</strong> ‘<strong>Whoever persists in performing twelve Rak’ah from the Sunnah (prayer), Allah (swt) will build a house for him in Paradise.</strong>”</p>
<p>Abu Dawood and Tirmidhi reported from Ummu Habiba, the wife of the Prophet ﷺ: I heard Messenger of Allah ﷺ saying: <strong>«</strong><strong>مَنْ حَافَظَ عَلَى أَرْبَعِ رَكَعَاتٍ قَبْلَ الظُّهْرِ وَأَرْبَعٍ بَعْدَهَا حَرَّمَهُ اللَّهُ عَلَى النَّارِ</strong><strong>»</strong> &#8220;<strong>Whoever prays regularly four Rak&#8217;at before and four Rak&#8217;at after the Zuhr prayer, Allah will forbid for him (from entering) the Hellfire</strong>.” [Albaani authenticated them as Sahih].</p>
<p>Tirmidhi reported and authenticated from Abdullah bin Amr (ra) that the Messenger of Allah ﷺ said:</p>
<p><strong>خَلَّتَانِ لَا يُحْصِيهِمَا رَجُلٌ مُسْلِمٌ إِلَّا دَخَلَ الْجَنَّةَ، أَلَا وَهُمَا يَسِيرٌ وَمَنْ يَعْمَلُ بِهِمَا قَلِيلٌ: يُسَبِّحُ اللَّهَ فِي دُبُرِ كُلِّ صَلَاةٍ عَشْرًا وَيَحْمَدُهُ عَشْرًا وَيُكَبِّرُهُ عَشْرًا، قَالَ: فَتِلْكَ خَمْسُونَ، وَمِائَةٌ بِاللِّسَانِ، وَأَلْفٌ وَخَمْسُ مِائَةٍ فِي الْمِيزَانِ. وَإِذَا أَخَذْتَ مَضْجَعَكَ تُسَبِّحُهُ وَتُكَبِّرُهُ وَتَحْمَدُهُ مِائَةً، فَتِلْكَ مِائَةٌ بِاللِّسَانِ وَأَلْفٌ فِي الْمِيزَانِ، فَأَيُّكُمْ يَعْمَلُ فِي الْيَوْمِ وَاللَّيْلَةِ أَلْفَيْنِ وَخَمْسَ مِائَةِ سَيِّئَةٍ؟</strong> قَالُوا: فَكَيْفَ لَا يُحْصِيهَا؟ قَالَ: <strong>«يَأْتِي أَحَدَكُمْ الشَّيْطَانُ وَهُوَ فِي صَلَاتِهِ فَيَقُولُ اذْكُرْ كَذَا اذْكُرْ كَذَا حَتَّى يَنْفَتِلَ فَلَعَلَّهُ لَا يَفْعَلُ، وَيَأْتِيهِ وَهُوَ فِي مَضْجَعِهِ فَلَا يَزَالُ يُنَوِّمُهُ حَتَّى يَنَامَ»</strong></p>
<p>“<strong>Two characteristics which a man performs except that he will enter Paradise. And they are easy and those who perform them are few: That you say &#8220;Subhanallah&#8221; ten times, &#8220;Alhamdulillah&#8221; ten times and &#8220;Allahu Akbar&#8221; ten times after every prayer</strong>.” He said: “<strong>That is 150 on the tongue and 1500 in the balance (for each day). When you go to bed, you should say, &#8220;Subhanallah&#8221;, &#8220;Al-hamdulillah&#8221;, and &#8220;Allahu Akbar&#8221; hundred times. And that is 100 on the tongue and 1000 in the balance. Who amongst you can do 2500 bad deeds on a day and night?&#8217;</strong>”. The Companions (ra) of the Prophet (aw) asked: “How is it that they are not counted?” The Prophet ﷺ replied: “<strong>Shaytan comes to one of you while he is praying and says “Remember such and such, remember such and such” until the man turns and perhaps he will not do it. And Shaytan comes to him while he is on the bed and makes him sleepy until he falls asleep</strong>.” In the narration of Abu Dawood, the wordings are: <strong>خَصْلَتَانِ أَوْ خَلَّتَانِ لَا يُحَافِظُ عَلَيْهِمَا عَبْدٌ مُسْلِمٌ إِلَّا دَخَلَ الْجَنَّةَ، هُمَا يَسِيرٌ وَمَنْ يَعْمَلُ بِهِمَا قَلِيلٌ&#8230;</strong> <strong>“Two characteristics or two qualities which a servant Muslim continues to perform except that he will enter Paradise. And they are easy and those who perform them are few…”</strong> Sheikh Mubarkpuri says in ‘<em>Tuhfathul Ahoodi’</em>: (”<strong>those who perform them are few</strong>” i.e. the description of performing it continuously).</p>
<p>Muslim reported the narration of Abu Musa al-Ashari that the Messenger of Allah ﷺ said: <strong>»</strong> <strong>«</strong><strong>تَعَاهَدُوا هَذَا الْقُرْآنَ، فَوَالَّذِي نَفْسُ مُحَمَّدٍ بِيَدِهِ لَهُوَ أَشَدُّ تَفَلُّتًا مِنَ الْإِبِلِ فِي عُقُلِهَا</strong> <strong>“Keep refreshing your knowledge of the Qur&#8217;an, for I swear by Him in Whose Hand is the life of Muhammad that it is more liable to escape than camels which are hobbled”.</strong> [And the wording of the Hadith is by Ibn Baraad].</p>
<p>The Prophet ﷺ was the most generous amongst the people. He ﷺ was the most generous during the month of Ramadhan. Jibreel (as) used to visit him and recite the Quran. The Prophet ﷺ used to be more generous than the gales, when Jibreel (as) met him. Jibreel (as) used to visit him every year and recite the Quran, once in each year of Ramadhan. During the year when the Prophet ﷺ passed away, Jibreel (as) recited the Quran twice. Perseverance in what Allah (swt) has obliged is amongst the obligations of Deen and a mark of steadfastness in the Straight Path. There is no leniency in the obligations and the Muslim is obliged to persevere with them without any choice.</p>
<p>Perseverance in routine Sunnah, particularly, and in good deeds generally is amongst the recommended actions (Mustahab) of Shariah. The Muslims have choice in doing it. A Muslim who performs them will be rewarded, whilst the one who leaves them will not be punished. Here, the hadith urges a Muslim to be perseverant, as much as possible, until the deeds occupy his time, and to initiate them even if they are little, for little things add up to be like mountain. Continuity of those deeds makes them innate to him, making him advance with them. He will be conscious of deficiency when he is busy. Thus the soul will be accustomed to ‘Ibadah and he will strive to seek the pleasure of Allah (swt).</p>
<p>It must be noted that the preoccupation of a Muslim with Sunnah and Nafils (recommended deeds) must never be at the expense of leaving the obligations, as this is not permissible. The most beloved deeds which Allah has imposed upon Muslim are obligations and then the recommended deeds (Nafil). The Messenger of Allah ﷺ said<strong>: </strong><strong>«</strong><strong>إنَّ اللَّهَ قالَ: مَن عادَى لي ولِيًّا فقَدْ آذَنْتُهُ بالحَرْبِ، وما تَقَرَّبَ إلَيَّ عَبْدِي بشيءٍ أحَبَّ إلَيَّ ممَّا افْتَرَضْتُ عليه، وما يَزالُ عَبْدِي يَتَقَرَّبُ إلَيَّ بالنَّوافِلِ حتَّى أُحِبَّهُ، فإذا أحْبَبْتُهُ: كُنْتُ سَمْعَهُ الذي يَسْمَعُ به، وبَصَرَهُ الذي يُبْصِرُ به، ويَدَهُ الَّتي يَبْطِشُ بها، ورِجْلَهُ الَّتي يَمْشِي بها، وإنْ سَأَلَنِي لَأُعْطِيَنَّهُ، ولَئِنِ اسْتَعاذَنِي لَأُعِيذَنَّهُ، وما تَرَدَّدْتُ عن شيءٍ أنا فاعِلُهُ تَرَدُّدِي عن نَفْسِ المُؤْمِنِ، يَكْرَهُ المَوْتَ وأنا أكْرَهُ مَساءَتَهُ</strong><strong>»</strong> <strong>“Verily Allah (swt) has said: ‘Whosoever shows enmity to a wali (friend) of Mine, then I have declared war against him. And My servant does not draw near to Me with anything more loved to Me than obligations I have obligated upon him. And My servant continues to draw near to me with nafil (supererogatory) deeds until I love him. When I love him, I am his hearing with which he hears, and his sight with which he sees, and his hand with which he strikes, and his foot with which he walks. Were he to ask [something] of Me, I would surely give it to him; and were he to seek refuge with Me, I would surely grant him refuge.</strong> <strong>I do not hesitate to do anything as I hesitate to take the soul of the believer, for he hates death, and I hate to disappoint him’.&#8221;</strong> [Bukhari].</p>
<p>This includes the continuity of performing night prayer, even at the time of milking the sheep. This includes the three days of fasting on the white days, i.e. 13<sup>th</sup>, 14<sup>th</sup>, and 15<sup>th</sup>, of every Hijri month or fasting on Monday and Thursday of every week. This includes the persistence in certain adkhar (Remembrance), reciting and memorizing the Quran, reciting Quran in the night prayers. This includes Salatul Dhuha (Morning voluntary prayer after sunrise), reciting Quran after Fajr until sunrise followed by Salatul Ishraq. This includes the continuity of praying voluntary prayers after Maghrib Salah, with particular Rak’as..</p>
<p>When a Muslim undertakes these voluntary, recommended deeds, he should not treat them similar to obligations. He must commit himself to the voluntary deeds and account himself from leaving them. He must not continue to perform them, if it leads to abandoning the obligation. These are Sunnah and they remain within their Shariah reality. And they come in the position after the obligation. When the voluntary deeds compete with the obligation, obligation is preferred and this will not be considered as breaking the continuity. A person may have occasional work, travel, sickness or the like and such things may cause the Muslim to leave the voluntary deeds, without having an intention of leaving them.</p>
<p>There also comes in the Sunnah that the Messenger of Allah ﷺ did certain voluntary actions sometimes, whilst leaving them at other times. So the Muslim takes that into account and this is better than the continuity of action. This includes Salatul Dhuha and reciting supplementary Surahs, other than Surah Fatiha, sometimes in the last two rak’aas of Dhuhr and Asr prayers and the like of it.</p>
<p>The best thing for a Muslim to proceed in continuous worshipping (Ibadah) with perseverance and persistence is to proceed in it gently. So he begins with the Ibadah that is light at first until he completes it and then he adds other Ibadah to it. In this way, he continues until most of his time is preoccupied with the remembrance of Allah (swt). This applies to the men and women who remember Allah (swt) a lot. Thus the Muslim occupies his time with the obedience to Allah (swt) by performing all what He (swt) commands in terms of obligations, without any leniency or delay, in performing it while he occupies the remaining time with Sunnah and Nafil (voluntary deeds). This preoccupation will improve the performance of obligatory actions when he proceeds them with Iman, content and satisfaction.</p>
<p>Allah (swt) says, <strong>ٱلَّذِينَ ءَامَنُواْ وَتَطۡمَئِنُّ قُلُوبُهُم بِذِكۡرِ ٱللَّهِۗ أَلَا بِذِكۡرِ ٱللَّهِ تَطۡمَئِنُّ ٱلۡقُلُوبُ</strong> <strong>“Those who have believed and whose hearts are assured by the remembrance of Allah. Unquestionably, by the remembrance of Allah hearts are assured.”</strong> [Surah Ra’d: 28]. Allah (swt) said, <strong>ٱلَّذِينَ إِذَا ذُكِرَ ٱللَّهُ وَجِلَتۡ قُلُوبُهُمۡ وَٱلصَّٰبِرِينَ عَلَىٰ مَآ أَصَابَهُمۡ وَٱلۡمُقِيمِي ٱلصَّلَوٰةِ وَمِمَّا رَزَقۡنَٰهُمۡ يُنفِقُونَ</strong> <strong>“Who, when Allah is mentioned, their hearts are fearful, and [to] the patient over what has afflicted them, and the establishers of prayer and those who spend from what We have provided them.”</strong> [Surah Hajj: 35]</p>
<p>&nbsp;</p>
<p><strong>Al-Waie Magazine</strong></p>
<p><a href="http://www.al-waie.org/archives/article/14498">Translated from Al-Waie Magazine Issue 406, Dhul-Qi&#8217;dah 1441 AH / July 2020 CE</a></p>
<div class='shareaholic-canvas' data-app='share_buttons' data-title='Gardens of Jannah: Actions of the Messenger ﷺ were Continuous (Deemah ديمة)' data-link='http://www.khilafah.com/gardens-of-jannah-actions-of-the-messenger-%ef%b7%ba-were-continuous-deemah-%d8%af%d9%8a%d9%85%d8%a9/' data-app-id='15615597' data-app-id-name='post_below_content'></div> </div>
<footer class="entry-meta">
<div class="entry-cats">
<span>Filed under: </span><a href="http://www.khilafah.com/category/concepts/" rel="category tag">Concepts</a>, <a href="http://www.khilafah.com/category/featured/" rel="category tag">Featured</a>, <a href="http://www.khilafah.com/category/concepts/islamic-culture/" rel="category tag">Islamic Culture</a> </div>
</footer>
</article>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/gardens-of-jannah-actions-of-the-messenger-%EF%B7%BA-were-continuous-deemah-%D8%AF%D9%8A%D9%85%D8%A9/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="http://www.khilafah.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<p class="comment-notes"><span id="email-notes">Your e-mail address will not be published.</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='47763' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7892d3972d" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="185" /></p> </form>
</div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div>
<div class="nav-wrap cf">
<nav id="nav-single">
<div class="nav-previous"><a href="http://www.khilafah.com/sri-lankan-governments-exploitation-of-the-covid-19-pandemic-in-cremating-muslims/" rel="prev"><span class="meta-nav">Previous Post</span>Sri Lankan Government’s Exploitation of the Covid-19 Pandemic in Cremating Muslims!</a></div>
<div class="nav-next"></div>
</nav>
</div>
</div>
<div id="blog-sidebar" class="default-sidebar widget-area" role="complementary">
<aside id="recent-comments-2" class="widget widget_recent_comments"><h3 class="widget-title">Recent Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Suleman Chunara</span> on <a href="http://www.khilafah.com/international-campaign-muslims-in-sri-lanka-suffer-anguish-in-life-and-death/#comment-24055">International Campaign: “Muslims in Sri Lanka Suffer Anguish in Life and Death!”</a></li><li class="recentcomments"><span class="comment-author-link">Zaeem Al Fathih</span> on <a href="http://www.khilafah.com/forced-cremation-of-muslim-covid-19-victims-in-sri-lanka/#comment-24034">Forced Cremation of Muslim Covid-19 Victims in Sri Lanka</a></li><li class="recentcomments"><span class="comment-author-link">Shan</span> on <a href="http://www.khilafah.com/the-total-lockdown-and-the-closure-of-mosques-is-a-new-confusion-of-power/#comment-24033">The Total Lockdown and the Closure of Mosques is a New Confusion of Power</a></li><li class="recentcomments"><span class="comment-author-link">Yasir</span> on <a href="http://www.khilafah.com/qa-the-use-of-animal-parts-organs-and-bones/#comment-24030">Q&#038;A: The Use of Animal Parts, Organs and Bones</a></li><li class="recentcomments"><span class="comment-author-link">Adam Kamal</span> on <a href="http://www.khilafah.com/views-on-the-news-28-nov-2020/#comment-24026">Views on the News – 28 Nov 2020</a></li></ul></aside></div>
<footer id="colophon" class="site-footer cf">
<p class="site-description">Serving the Ummah since 1996</p>
<div id="footer-social-nav">
<h3 class="social-nav-title">Social</h3>
<ul id="menu-primary" class="menu"><li id="menu-item-23095" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23095"><a href="https://twitter.com/KhilafaRashida">Twitter</a></li>
<li id="menu-item-23097" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23097"><a href="https://www.facebook.com/AlKhilafahGlobal">Facebook</a></li>
<li id="menu-item-23170" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23170"><a href="http://Instagram.com/TheKhilafah">Instagram</a></li>
<li id="menu-item-23171" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23171"><a href="http://YouTube.com/KhilafahTV">Youtube</a></li>
</ul> </div>
<div id="site-info">
<ul class="credit" role="contentinfo">
<li>Khilafah.com - Building a global movement for Khilafah</li>
</ul>
</div>
</footer>
</div>
</div>
<script type='text/javascript' src='http://www.khilafah.com/wp-includes/js/comment-reply.min.js?ver=5.1.1'></script>
<script type='text/javascript' src='http://www.khilafah.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=13.1'></script>
<script type='text/javascript' src='http://www.khilafah.com/wp-includes/js/wp-embed.min.js?ver=5.1.1'></script>
<script async="async" type='text/javascript' src='http://www.khilafah.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.1'></script>
</body>
</html>